解决sublime text3无法安装插件问题

发表于 2019-06-26 11:28:49   |   下载附件   |   字体:
sublimesublime 无法安装插件问题安装插件

在给sublime text3安装插件时,出现以下错误



通过View > Show Console

查看错误为:Package Control: Error parsing JSON from channel https://packagecontrol.io/channel_v3.json.


网上查了找到的方法就是改变安装channel_v3.json的配置文件。

解决方法:
Package Control.sublime-settings]修改方法:
Preferences > Package Settings > Package Control > Settings - User


添加以下代码:
"channels":[
    "http://cst.stu.126.net/u/json/cms/channel_v3.json",
    //"https://packagecontrol.io/channel_v3.json",
    //"https://web.archive.org/web/20160103232808/https://packagecontrol.io/channel_v3.json",
    //"https://gist.githubusercontent.com/nick1m/660ed046a096dae0b0ab/raw/e6e9e23a0bb48b44537f61025fbc359f8d586eb4/channel_v3.json"
],


再次安装插件,即可成功